OpenRTK330LI GPS Results and Firmware Upgrade

Thank you very muc. my email: jxie@ipoz.net

Hi,

First of all, thank you again for your quick response and sending us the solutions. After following the steps, both Yellow and Green LEDs did not flash. Here I give some details:

In Step 1(b), after I connected the micro-USB to PC, EVB was powered on, but Green LED did not flash. Anyway, I continued to work on Step 2, 3 and 4. In Step 4(a), I did find "Program Ok: instance 0" at the end of "log.txt" file (see the link below)

https://sites.google.com/site/johnrhxie2018/itrain2019/rd2/log1.txt?attredirects=0&d=1

Then, I continue to Step 4(b)(c) and to Step 5(a)(b). In Step 5(b), it displayed the successful message "Upgrade operation is finished, your device is updated" . However, in Step 5(c), both Yellow and Green LED did not flash.

I am looking forward to your solution.

Thank you.

John

@John-Xie from "log.txt" we see upgrade GNSS firmwaer succedded, and by "***your device is updated" we see INS firmware updated successfully as well. Did you have RTK_INS v 1.2.2 the latest version updated?

I tried upgrading to RTK_INS v1.2.2. However, in the device info, it says "0.1.1".

By the way, right now both Green and Yellow LEDs do not flash at all after upgrading the GNSS firmware.

The ship date of our OpenRTK330LI is April 10,2020. Would you please send me the GNSS firmware (the version on or before the ship date)?

@John-Xie we use the latest version, v1.2.2 is the correct version, but we updated the firmware for many times, never met this case, 0.1.1 is way back version; at least Yellow LED has to be on, meaning power on; if no yellow LED, where you find the device info?

After following the procedure to flash the GNSS_RTK_SDK firmware, both Yellow and Green LEDs do not flash. Right now I cannot get back to the original one with both Yellow and Green LEDs flash after the power is on (Red LED near the USB port is on).

In my first report shown at the top, I have already reported "The 2nd iusse: I tried to upgrade the module RTK_INS firmware Ver.1.2.2. It did say "Upgrade operation is finished. your device is updated". However, after restarting the device, the firmware version is still Ver.0.1.1 (see Figure 1.4(b) in the attached PDF). What did I miss for this issue?".

I just noticed that my case is similar to the case reported in the topic OpenRTK300/OpenIMU EVK ( kylerlaird • 20 Mar 2020, 13:07) by SwingW:

"Hello, I am operating according to the online documentation tutorial, but I still have not received the gnss signal and imu data, and the open rtk330EVB does not blink when the power is connected to the yellow LED and the green LED. I want to ask you know what is the reason for this Is it"

Hi,

Now Yellow LED is flashing after I changed the -d 0x10000400

AceinnaGnssTool.exe program -f t5 -i C:\jx20\1589445373736169.bin -o log.txt -c COM24 -b 115200 -m SQI -d 0x10000400 -e TRUE -r TRUE

to -d 0x10000000:

AceinnaGnssTool.exe program -f t5 -i C:\jx20\1589445373736169.bin -o log.txt -c COM20 -b 115200 -m SQI -d 0x10000000 -e TRUE -r TRUE

But the Green LED does not flash. Thus there is no GPS and IMU data in OpenRTK Monitor.

Hi,

After I set up the NTRIP, the Red LED (LED2) starts to flash. That meas "receiving the BASE RTCM data". The Green LED does not flash.

@John-Xie his issue is resolved after upgrading GNSS_RTK_SDK successfully

@John-Xie the file zip i shared with you on Google Drive, the flasing command has no "-d 0x****" option, let it be default

@John-Xie I highly recommed you follow the steps in the shared file zip and try again, thanks

The Step 3 in the PDF file that is included in the zip file shared with me on Google drive gives the following command with the option -d 0x10000400:

Aceinna_gnss_tool.exe program -f t5 -i C:\Users\Downloads\1585832803957169.bin -o log.txt -c COM6 -b 230400 -m SQI -d 0x10000400 -e TRUE -r TRUE

while the READ me that is included in the zip file provides the following command without the option -d 0x010000400:

.\AceinnaGnssTool.exe program -f t5 -v cut2 -i <PATH TO FIRMWAER FILE> -o log.txt -c COM<PORT NUMBER> -b 115200 -m SQI -e TRUE

Hi,

I tried it again and cannot fix it. Here is my detailed report for this trail:

https://sites.google.com/site/johnrhxie2018/itrain2019/rd2/JX_Update_200526.pdf?attredirects=0&d=1

When we received this device, we were able to see the flashing of both Green and Yellow LEDs and get both IMU data and GPS signals. At that time, we have only 2 issues:

  1. GPS Data: Longitude, Latitude and Height all are "0"
  2. Firmware Version: it is still 0.1.1 after we followed the procedure to upgrade RTK_INS App v 1.2.2

@John-Xie yes, i can see the whole process went through, but at your step 1, after the boot switch is put away from RJ45 jack position, the Green LED should keep blinking, yet your green LED did not blink, do you have a QQ and wechat we can talk over this?

Hi,

Here is my wechat ID: CalXie

Sorry, my WeChat ID is: gzmgdg

My question: The openrtk330Li development board cannot burn the GNSS_RTK_SDK firmware. Even the tutorial you provide will find that the burning fails. Solution: Use the firmware burning software provided by the staff (the GNSS_RTK_SDK firmware is integrated, there is a need to contact the staff in Wuxi, China), and the j-link must be unplugged during the burning, and the operation will be successful

Log in to reply