OpenRTK330LI GPS Results and Firmware Upgrade

@John-Xie his issue is resolved after upgrading GNSS_RTK_SDK successfully

@John-Xie the file zip i shared with you on Google Drive, the flasing command has no "-d 0x****" option, let it be default

@John-Xie I highly recommed you follow the steps in the shared file zip and try again, thanks

The Step 3 in the PDF file that is included in the zip file shared with me on Google drive gives the following command with the option -d 0x10000400:

Aceinna_gnss_tool.exe program -f t5 -i C:\Users\Downloads\1585832803957169.bin -o log.txt -c COM6 -b 230400 -m SQI -d 0x10000400 -e TRUE -r TRUE

while the READ me that is included in the zip file provides the following command without the option -d 0x010000400:

.\AceinnaGnssTool.exe program -f t5 -v cut2 -i <PATH TO FIRMWAER FILE> -o log.txt -c COM<PORT NUMBER> -b 115200 -m SQI -e TRUE


I tried it again and cannot fix it. Here is my detailed report for this trail:

When we received this device, we were able to see the flashing of both Green and Yellow LEDs and get both IMU data and GPS signals. At that time, we have only 2 issues:

  1. GPS Data: Longitude, Latitude and Height all are "0"
  2. Firmware Version: it is still 0.1.1 after we followed the procedure to upgrade RTK_INS App v 1.2.2

@John-Xie yes, i can see the whole process went through, but at your step 1, after the boot switch is put away from RJ45 jack position, the Green LED should keep blinking, yet your green LED did not blink, do you have a QQ and wechat we can talk over this?


Here is my wechat ID: CalXie

Sorry, my WeChat ID is: gzmgdg

My question: The openrtk330Li development board cannot burn the GNSS_RTK_SDK firmware. Even the tutorial you provide will find that the burning fails. Solution: Use the firmware burning software provided by the staff (the GNSS_RTK_SDK firmware is integrated, there is a need to contact the staff in Wuxi, China), and the j-link must be unplugged during the burning, and the operation will be successful

John Xie, did you solve your issue? If yes can you share it with us?

I have a very similar issue. I have an OpenRTK330Li where I wanted to extract the Integrated GNSS/INS solution. I attempted upgrading the firmware, and now red and green lights don't blink anymore.

Here is a sequence of things I tried:

  1. Board was working fine in the beginning, I updated the RAWDATA APP using VScode ( and was able to visualize both IMU and GNSS data on Navigation Studio

  2. Tried flashing GNSS_RTK_SDK and the newest version of GNSS_RTK_INS using the VScode process but It wouldn't upgrade (It would get to 100% and never ended) on Aceinna Studio

  3. Tried also using the google drive steps provided here and no success.

  4. At this point, feeling a bit frustrated, I saved the system image and tried to recover it, then, yellow and green don't turn on anymore and neither the google drive update nor the VScode procedures work.

It has been a battle of a few days and couldn't find a clear solution to me or a debug process that I could try.

Please, any help is very welcome

Log in to reply