Changing Packet Type from s1 to pS


I’ve been reading data from the OpenRTK330LI using the USB serial port and have been successful in getting the "s1" data packet and decoding it. However, I would like the device to output the “pS” data packet, as it gives the roll, pitch, and yaw angles.

So far I have attempted sending UART commands to change the userPacketType from “s1" to “pS” using the Update Parameter command on the Navigation Studio. I have also tried importing the RAWDATA firmware example into Visual Studio and changing the “.userPacketType” in “user_config.c” from “s1” to “pS”. Neither of these two methods have worked out.

Please can you help me with the process of changing the received USB serial data packet from the device from “s1” to “pS”?

Would I be able to get the roll, pitch, and yaw angles more easily by setting up and using the CAN port?

I have the same question. Can anybody answer, please?

Thank you for sharing your knowledge with us.

@Lauren-Manton Thank you for sharing your knowledge with us.

Log in to reply