How to recover device from bricked state after online update fails?

Late last year (2021), we ordered an OpenRTK330 Evaluation Kit. After receiving the device, I followed the instructions found on the readthedocs page as well as here and could get the IMU data but not the GPS readings using the apps page, most likely because the device was indoors. However, I could not connect via http://openrtk/.

Decided to upgrade the device online by going to However, it failed before completing the upgrade and could not use the device afterward. The green light just kept blinking.

I then followed instructions from other posts on this forum, such as here and here but none of the solutions worked for me. I then tried upgrading the firmware manually using the ST-LINK debugger on a Windows 10 device but even after that seemed to complete, the device just has the red light on and still not even the python drivers can see the device and we still cannot get even the IMU data.

I should note that I do not have a backup recovery image to load.

  • Can someone offer detailed steps to fix it?

  • Does someone have a recovery image that can be used to recover the system so we can use it again?

Thanks for your help.

@privvyledge Please burn the firmware through STlink and I will provide you with a firmware file.OpenRTK330L_GNSS_RTK_INS_v23.01.bin

@chengyong so that this thread can be useful for anyone that searches through a search engine. Can you:

  1. Include detailed steps to use the file you posted (links would be helpful).
  2. Does the file you posted include calibration data? If not, is there a way to recalibrate to factory defaults?


@privvyledge Refer to the link part 9(330)
If you haven't changed the calibration data, you can ignore it.Just burn the firmware.

Log in to reply