OpenIMU300ZA firmware & calibration data

Dear Aceinna team,
We are using your OpenIMU300ZA module, P/N: 8350-3885-01
Serial Number: 1908400166

I tried to use Microsoft Visual Studio Code + PlatformIO + Aceinna extension. I opened your IMU example app, then compiled it successfully and then send to flash memory of your STM32F405 MCU. But when I tried to connect the module to Aceinna Navigation Studio, it failed. I checked the serial data communication, no response from the module at all.

I think I have overwritten the calibration data and then made the module unusable. Could you send me the original firmware to work with the Aceinna Navigation Studio?

Thank you and best regards,
Edy Gunawan

@Edy-Gunawan
Hi Edy, you are welcome! I could download the image normally, please double check your device connection and network.
ff1f4e78-be27-497f-8557-7b89ba778b63-image.png

25ee7edc-5e2d-413c-918d-a1f74fb43883-image.png

Hello Li YiFan,
I solder cables to a 1mm-female header, then insert the header to the OpenIMU300ZA 20-pin connector. Now the module shows data in the Aceinna Developer Studio screen. Thank you.

When I tried to update the application, through Code ==> Apps ==> INS Application
Message shown: Upgrading , please don't disconnect your IMU device
Initializing . . .
Then after several minutes, nothing happens, the same message is still shown. How long should I wait?
Please advise, thank you.

@Edy-Gunawan Hi Edy, the UART2 TX (pin 17) and UART2 RX (pin 19) is debug interface. please try user interface.

https://openimu.readthedocs.io/en/latest/300ZI/pinout.html
2019-12-05_08h26_28.jpg

BTW, please also send us a photo that your board connection.

Pin 7, the UART/SPI interface selector is already connected to GND.
Pin 13, 14, 15 are connected to ground
Pin 10, 11, 12 are connected to 3.3 volt supply.
Is there any other pin to be checked?

Hello Cek,
thank you for sending me the file. I have followed the steps to upload the bin file into the OpenIMU300ZA using ST-Link.
Then the UART2 TX (pin 17) and UART2 RX (pin 19) are connected to serial USB converter. The module still does not send any response.
Tested with NAV-VIEW 3, raw data sent, but no RX data arrived.
Is there any way to test the firmware? Any byte stream to test, including the check sum bytes?
What is the default UART setting, is it 115200 baud, 8 bit data, no parity, 1 stop bit?

Thank you

Sorry to hear that you over-writed the calibration data, forgot to backup the whole EEPROM of IMU before
now we have to created one EEPROM whole bin file for you: (pls remember to backup whole EEPROM bin file(steps) firstly in future)
1908400166_1.1.0.bin

pls upload the bin file under steps in topic_4 strictly.

Log in to reply