OpenIMU Windows 1.1.1 Continuously Testing Ports

I am working with an OPENIMU300ZA EVK.
I am able to connect using the Jtag
When I attempt to run the OPENIMU Windows 1.1.1 The program scans for hours and never stops.
The .JSON is never created.

I have tried this on 2 multiple Windows 10 computers at 2 different internet sources (Home and Work).

Any direction would be greatly appreciated. I am very excited to be working with this hardware!Annotation 2019-12-30 134636.png

@Kai-Justice Hi Kai Justice,
1.After you run OpenIMU-windows-1.1.1.exe, The json file will be automatic downloaded in folder app_config 2019-12-31_09h00_29.jpg , if you can not get the app_config, please download the app_config ifrom the link, 6. share the JSONs corresponding Server_1.1.1.exe.

  1. Do you program the 300 IMU Unit? please refer to before you do OpenIMU development.

  2. How about changing a COM port and connect?

  3. If you connect 300 Unit with PC com port, could you get data from SSCOM with User Uart interface? Normally the user interface is the first com port of the four, COM18 in your test environment for instance.

LiYiFan, Thank you so much for your reply.

  1. I have downloaded OpenIMU-windows-1.1.1. The app_config folder populates, but the "connection.json" files do not create. I just now tried downloading from "6.Share the Jsons corresponding Server_1.1.1.exe." I copied and pasted that in the OpenIMU-windows-1.1.1 folder and reran the .exe. Still no connection to:
  2. I have not programmed, I did read the warning, I did save the file in a "safe" place.
  3. I have desktop and laptop (Both windows 10), I just tried the above steps and again just now tried changing ports on both computers. Changing ports or computers did not fix.
  4. I was trying with HTERM with no luck. I will go look for SSCOM to see if I can do better.


Here is the sscom at 115200

I did try again at each baud rate. I do not get the 55 55 7A 31 as the topics described.
I also tried Hterm again with better luck.

I was told no one prior to me had worked with this module, but I suspect a prior colleague had tried without others' knowledge.

@Kai-Justice Hi Kai Justice, sorry for the late msg. You should update the firmware version and try again. Please upload the OpenIMU300ZI IMU app bin file with Stlink, and note that you should download from start add: 0x08010000. the 300 downloading process please refer to 9. how to upgrade new FW with ST-LINK? in

the bin file could be download from 2020-01-02_10h28_16.jpg

Li YiFan,
Thank you so much! This did the trick, and I learned a lot along the way, appreciate your direction.

@Kai-Justice Your are welcome! Thanks for using OpenIMU.

Log in to reply