missing indices.h

I'm finally getting around to playing with my evaluation kits. I immediately ran into a problem trying to build. It happened with each of the three examples I tried. I'm hoping that I missed something basic. I tried the lookup as suggested but no results. Help?


> Executing task in folder 200912-095627-VG_AHRS: platformio run <

Processing OpenIMU300RI (platform: aceinna_imu; board: OpenIMU300)
Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: https://docs.platformio.org/page/boards/aceinna_imu/OpenIMU300.html
PLATFORM: Aceinna IMU (1.3.0) > Aceinna OpenIMU 300
HARDWARE: STM32F405RG 120MHz, 128KB RAM, 1MB Flash
DEBUG: Current (stlink) External (blackmagic, jlink, stlink)
 - toolchain-gccarmnoneeabi 1.70201.0 (7.2.1)
LDF: Library Dependency Finder -> http://bit.ly/configure-pio-ldf
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 2 compatible libraries
Scanning dependencies...
Dependency Graph
|-- <OpenIMU300-base-library> 1.1.8
|   |-- <Core> 1.0.4
|-- <Core> 1.0.4
Building in release mode
Compiling .pio/build/OpenIMU300RI/lib082/OpenIMU300-base-library/Platform/CAN/src/taskCANcommunicationJ1939.o
Compiling .pio/build/OpenIMU300RI/lib082/OpenIMU300-base-library/Platform/Core/src/DataAcquisitionSupport.o
.pio/libdeps/OpenIMU300RI/OpenIMU300-base-library/Platform/CAN/src/taskCANcommunicationJ1939.c:23:10: fatal error: indices.h: No such file or directory

* Looking for indices.h dependency? Check our library registry!
* CLI  > platformio lib search "header:indices.h"
* Web  > https://platformio.org/lib/search?query=header:indices.h

 #include "indices.h"
compilation terminated.
Compiling .pio/build/OpenIMU300RI/lib082/OpenIMU300-base-library/Platform/Core/src/comm_buffers.o
*** [.pio/build/OpenIMU300RI/lib082/OpenIMU300-base-library/Platform/CAN/src/taskCANcommunicationJ1939.o] Error 1
Compiling .pio/build/OpenIMU300RI/lib082/OpenIMU300-base-library/Platform/Core/src/config_fields.o
============================ [FAILED] Took 1.77 seconds ============================
The terminal process "platformio 'run'" terminated with exit code: 1.

Ah...it looks like this only works on case insensitive file systems. I found Indices.h, and made the change. Then ran into a missing UserMessagingUart.h, found UserMessagingUART.h, made that change. I was able to compile the AHRS code.

Log in to reply