Not Serial Com in OpenIMU 335RI


I have been trying to connect to my development board of the IMU335RI via the RS232 connector. I used a ST-LINK v2 to upload the OpenIMU355RI/VG example from the Visual Studio Aceinna extension.
Then I run the OpenIMU server app to connect with the Aceinna Navigation Studio. I get connected to the Studio but not with the IMU, thus there is no data on the screen.

Aceinna NAVStudio


I'm using a FT232R module from SparkFun to make the rs232 to USB conversion. I also set these parameters on the COM port:

COM parameters

Is there anything I'm missing? Should I modify a code line before upload the firmware to the IMU?

@spacelabElectronic ,to connect the Studio, you should open the python driver first. This is the link :
If you just want to get data , you can also use the Naview , I have posted a Naview 3.5.12 file in the forum before, you can search it

Hi @zrs I tried with the Naview, but same problem there is no comm between the IMU and the app. I connected a logic analyzer to see if there is at least some lose bits, but nothing there, just the RX channel down and the TX high.

You can first check whether there is a corresponding serial port through the device manager of the computer. In addition, when NAVIEW is connected, is the indicator line at the bottom l green or red? If it is green, you can set the packet sending rate in the
unit configuration of configuration