Hi everyone,

I've got OpenIMU300ZA EVK board. SN:1908400166. I connected to the device from python program and was able to fetch and record the data.
2023-05-05 00:36:02,578 - INFO: Connected Device info # Connected OpenIMU #
Device: OpenIMU300ZA5020-3885-01 1.0.22 SN:1908400166

Today I tried integrate GPS in the device by uploading the INS firmware. initially it worked and started showing GPS locations but soon it crashed automatically & went into bootloader mode.

2023-05-17 15:55:05,681 - INFO: Connected Device info # Connected OpenIMU #
Device: OpenIMU_Bootloader_4.0.3. Unit SN:1908400166

But when I tried uploading new bin file using STlink debugger, the program got uploaded but it is not connecting now. What to do? latest messages are here

2023-05-17 16:31:07,924 - INFO: try to use connected port COM17 in history
2023-05-17 16:31:07,985 - INFO: try COM1:460800
2023-05-17 16:31:08,113 - INFO: try COM17:460800
2023-05-17 16:31:08,193 - INFO: COM1 : 460800 open failed

I think I lost the firmware and bootloader both. I don't even have the backup image file with me. Please help me to fix this problem.

Best Regards,
Akshay Kumar