How to propose changes to the core libraries ?

Since I want to get covariance values, I was thinking I could add the relevant code to the core libraries and propose them for inclusion on GitHub. What would be the process to propose these changes ? Could someone point to me to documentation on how to use a custom version of a dependency (so that I use my fork of the core libraries instead of the AceINNA distributed ones) ?


What changes are you suggesting? Do you want to output the process covariance values to your system and want to add a getter to the firmware? Let me know and I will either answer you directly or forward you the most appropriate person.


Well. I've done the changes. What I am asking is whether you have considered including external contributions, and if yes how. I've originally created an issue on GitHub but since there's still no answer I'm guessing noone is listening there (unlike here, thanks !).

We also have generic changes to the INS app. Would you be interested in those ?

@Sylvain-Joyeux said in How to propose changes to the core libraries ?:

We also have generic changes to the INS app. Would you be interested in those ?

Specifically, the changes listed in

Hi Sylvain,

I tried to follow the above link to firwares-imu... on but it doesn't seem to exist. I am interested to look at the INS app changes.




I will confer with the people who are currently developing the algorithms and who control the firmware to find out their thoughts on this. I will get back to you once I hear from them.



Just as Simon pointed out, I tried to look over your modifications to the EKF algorithm as well but the link doesn't exist.



Any updates on the INS app?

I tried your drivers-imu_aceinna_openimu (for Rock) with the firmware in the in the folder and just got a core dumps- is the the correct firmware bin?

unbuntu 16.04 LTS:

openimu serial:///dev/ttyUSB0:115200 write-firmware INS_1-0-0_TW.bin
contacted unit in bootloader mode at serial:///dev/ttyUSB0:57600
firmware update successful

./openimu serial:///dev/ttyUSB0:115200 info
terminate called after throwing an instance of 'iodrivers_base::TimeoutError'
what(): readPacket(): no data waiting for data. Last wait lasted 3ms, out of a total timeout of 1000ms
Aborted (core dumped)


  • Looks like the baud rate for INS_1-0-0_TW.bin firmware defaults to 57600. Then the output is fine.

  • Also note the GPS input is on UART 1 (Serial Channel 1) NOT UART2 (Serial Channel 2) which is normally designated for GPS.


Log in to reply