Cannot connect to OpenIMU330BI EVK

I recently purchased an OpenIMU330BI EVK. After dozens of attempts, I cannot connect to the OpenIMU Monitor at

I downloaded the "IMU Server Ready-to-Use (Windows)" on my Windows 10 computer. I also updated the firmware on the OpenIMU330BI to OpenIMUBI_1.1.1 using the STM32 St-Link Utility. When I run Server_win32_1.1.1, COM7, COM1, COM8, and COM9 are successfully checked, then I get the message "Cannot configure port", and the terminal window suddenly closes.

Hi Say,
What is the package type from uart interface output? could you send me to check, for instance: 55 55 XX XX XX.

if you follow the link and upload firmware , and then get the data package 55 55 7A 31 XX XX ... via uart interface, will support the python driver connection.

Change another USB port, keep connection with PC directly with out a hub; restart you operating system then.
check serial message by serial tool, baud rate: 115200 or 57600, confirm whether 55 55 7A 31 included in hex displaying mode.


I changed USB ports twice, restarting the operating system each time. The ST-Link is directly connected to the USB hub without a USB hub, which it has been all along. Using the Target > Option Bytes utility in ST-Link v4.5.0, I set Pages 58-63 to have Write Protection as shown in Li YiFan's link above. The screen shot from the ST-LINK > Printf via SWO viewer utility in St-Link is shown below. It does to indicate the baud rate. How else can I check the baud rate and observe the hex displaying mode?


  1. about where to check the hex mode data? pls download one serial communication tool, which is not in ST-LINK and it is another separate SW tool in windows, such as: HTerm or SSCOM or serial assistant and so on.. you can get serial data by it. and show pic to us of your data.

  2. how about the status of 6 Pages(58-63) at first when you first time got and use it? is Write Protected or not?

if at first the 6 pages not protected in above question, pls finished the uploading from Li YiFan's link above.

  1. you mentioned " I also updated the firmware on the OpenIMU330BI to OpenIMUBI_1.1.1 using the STM32 St-Link Utility", pls give me youre SN number? mine SN is: 1927300538.

@Li-YiFan said in Cannot connect to OpenIMU330BI EVK:

if you follow the link and get

Hi Li,

I followed the link you provided:

The webpage at the link provided above shows a set of screenshots for the ST-LINK program. I was not able to find the data package 55 55 7A 31 XX XX anywhere in that webpage. Can you verify that you sent me the correct link?

@say the meaning fo Li is that: you flashed/upload the IMU-FW by the link he supplied, and then it will worked well.
after working well you can get the serial data by serial tool and receive the data like: 55 55 7A 31.

so pls refer to my comments above? and we can go on the discussion..

for serial tool get data and check FW version, pls refer to summary topic link of open-imu family:

Hi say,
I mean if you could get the 55 55 7A 31 from uart interface, after OpenIMU330BI updated the openimu330BI firmware. or you could save your OpenIMU330BI image bin file and send to us to check.


Hi cek,

Here's a screenshot of the data from HTerm on COM14:


The last 6 Pages (58-63) are write protected when I first open the Target > Settings > Option Bytes window.

My Serial Number from the label on the OpenIMU330BI EVK is:


Hi cek,

Here's another screenshot of the HTerm data with the data type set to Hex and the data scrolled back to the beginning. The first few bytes do indeed read 55 55 7A 31 as you can see.


your version of FW is 1.1.1, but calibrated area is broken, may be from your first flasing 1.1.1 you mentioned.

@say pls download the whole EEPROM bin file which include bootloader, fw and calibrated data, prepared for you. 1927300441_330BI EVK_whole EEPROM.bin

then pls follow below topic_5 steps to upload the bin to your IMU330:

reset the power, you should connect the ANS web.


Hi cek,

I installed the EEPROM bin file which you sent to me exactly according to the instructions under section 5 of the link above, starting at location 0x08000000, with a size of 0x30000. I set the 6 Option Bytes afterward and restarted the IMU board. I could not get the IMU to connect. I repeated the procedure again. I still cannot connect to the IMU with the OpenIMU Monitor. What should I do?

  1. check the serial data, what is sending from IMU now? your pic

I cannot get any data from the IMU over HTerm.

After establishing communication with the ST_LINK Utility, I tried to connect to each of the 5 COM ports using HTerm while the ST-LINK/V2 debugger LED is flashing alternately green and red. I could not get any data from the IMU over HTerm.

I also disconnected the IMU with the ST-LINK Utility and then again tried to connect to each of the 5 COM ports using HTerm while the ST-LINK/V2 debugger LED is constant red. I could not get any data from the IMU over HTerm.

  1. unlock the sectors
  2. upload bin file
  3. lock the sectors
  4. restart the IMU
    if right steps, it will working on well IMU HW.
    pls show pics of above steps, let's try again.


Hi cek,

I performed the steps above exactly as listed. Here is a screenshot of the ST-LINK Utility after successfully uploading the bin file, locking the sectors, and restarting the IMU:

I immediately saw good data over HTerm on COM14:

However, I still cannot connect to the OpenIMU Monitor at

What next steps should I take?

@say Hi Say,Now you have flashed the right image, the unit output the z1 package via uart interface. please use chrome browser, download the "IMU Server Ready-to-Use (Windows)" and try again. 2019-11-22_16h55_31.jpg 2019-11-22_16h53_10.jpg


Hi Li-YiFan,

I downloaded the IMU Server Ready-To-Use (Windows) using the Chrome browser and installed it as shown above. I still cannot connect to the IMU using ANS. After opening ANS, when I run Server_win32_1.1.1, a DOS console window opens briefly as shown here:


It gives the message as shown: "Cannot configure port, something went wrong. Original message: .."

How should I correct this problem?

First, pls save(backup) whole EEPROM bin file, and send to us. we need to check deeply.
follow the steps in topic_5, address 0x08000000, size 0x30000.

Second, pls use the testing server.exe try again, if still not, pls send to us the Server_log file which in same file with server.exe
thanks a lot.

Log in to reply