Flashing default firmware after "Full chip erase"

I suffered a failure during an upload with Visual Studio Code. Since nothing worked as before after the failure, I finally decided for a "Full chip erase" with STM32 ST-LINK Utility.

After erasing, I successfully flashed the bootloader with "OpenRTK330L_Bootloader_v1.1.1.bin" as documented in the tutorials. Unfortunately I am now stuck here! As also suggested by the tutorials, I created an emergency backup of the shipped image. Obviously I must have done something wrong since my emergency backup is not flashing with the comment "File size bigger than the flash memory size".

First questing:
is there a way to flash one of the default firmware (e.g. OpenRTK330L_GNSS_RTK_INS_v23.01.bin) to the EVK? If yes, how to accomplish that?

Currently I face the green LED on the EVK flashing and I cannot communicate with the USB bus. I tried on Ubuntu 18.04 and Windows 10 with the python-openimu tool. Booth worked before the chip erase. Now the "--console-log" output repeats as shown below instead of connecting.

Second question:
How to connect with USB.

ans-devices.exe --console-log --cli
2021-01-28 10:11:48,882 - INFO: try to use last connected port COM24 460800
2021-01-28 10:11:53,031 - INFO: start to connect serial port
2021-01-28 10:11:53,031 - INFO: try to use connected port COM24 in history
2021-01-28 10:11:53,031 - INFO: try to use connected port COM25 in history
2021-01-28 10:11:53,031 - INFO: try to use connected port COM26 in history
2021-01-28 10:11:53,031 - INFO: try to use connected port COM27 in history
2021-01-28 10:11:53,031 - INFO: try COM25:460800
2021-01-28 10:11:53,131 - INFO: try COM26:460800
2021-01-28 10:11:53,147 - INFO: try COM27:460800
2021-01-28 10:11:57,994 - INFO: try COM24:460800
2021-01-28 10:11:59,251 - INFO: try COM27:115200
2021-01-28 10:11:59,267 - INFO: try COM26:115200
2021-01-28 10:12:01,200 - INFO: try COM25:115200
2021-01-28 10:12:03,850 - INFO: try COM24:115200
2021-01-28 10:12:04,923 - INFO: try COM27:57600
2021-01-28 10:12:05,039 - INFO: try COM26:57600
2021-01-28 10:12:06,692 - INFO: try COM25:57600
2021-01-28 10:12:09,540 - INFO: try COM24:57600
2021-01-28 10:12:10,506 - INFO: try COM27:230400
2021-01-28 10:12:10,590 - INFO: try COM26:230400
2021-01-28 10:12:12,536 - INFO: try COM25:230400
2021-01-28 10:12:38,194 - INFO: try COM27:38400
2021-01-28 10:12:38,364 - INFO: try COM26:38400
2021-01-28 10:12:38,864 - INFO: try COM24:230400
2021-01-28 10:12:39,215 - INFO: try COM25:38400

Any help would be highly appreciated.

It turned out that I read the initial image with a size box of 0x200000 instead of 0x100000. Fortunately, I restored the original image after some byte modifications. This solved my issue.

Log in to reply