Building "RTK_INS" example in "platform-aceinna_imu" from source

I am unable to build the latest firmware from source provided at I cloned the respository, changed the directory into examples/OpenRTK330LI/RTK_INS, modified the platform.ini ([env:OpenRTK330LI] and board = OpenRTK330L) followed by executing pio run.

I described the exact output here. Did someone successfully build the firmware from source? If yes, could you please point out my mistake.

I tried with the other example app (RAWDATA). Still no luck. Can someone else please try to compile the current state of the project for the "OpenRTK330L" board.
The error log for the my attempt with the RAWDATA app is here

Hi I will have a check with the raw data app, and get back to you asap. Thanks, Yudan

@Yudan Thank you. Just for now: could you at least confirm my issue? Best Thierry

I also cannot get this to build. I had a different error at first, but I was able to work around that issue and then I got the exact same error as you.

@Thierry-Fredrich @Taylor-Alexander Thanks for your suggestions. I have checked these two apps.
1、RAWDATA is ok. I think you should check your OpenRTK-base-library version in the file path 'RAWDATA.pio\libdeps\OpenRTK'. Version 1.0.6 is ok. If the version is not 1.0.6, you should delete the OpenRTK-base-library and build the project again. It will auto pull OpenRTK-base-library@1.0.6 which is set in platformio.ini.1616486708(1).png
2、RTK_INS has problem with OpenRTK-base-library@1.0.8. We will fix this in the next released version. Or it can be solved by next steps:
0)、delete 'RTK_INS.pio\libdeps\OpenRTK'
1)、clone the newest OpenRTK-base-library at
2)、remove the line 'lib_deps = OpenRTK-base-library@1.0.8' in 'OpenRTK330LI\RTK_INS\platformio.ini'
3)、copy the newest OpenRTK-base-library code to the file path '\RTK_INS.pio\libdeps\OpenRTK\OpenRTK-base-library\'
4)、build project

@Yu-Mingjin : thank you so much for taking the time to report on this. Using your suggestions, I successfully compiled both examples.

Thank you! I can also compile it now.

Incidentally I am not using Eclipse or anything. I am on linux and prefer the command line. I am able to compile it with "platformio run" in the directory platform-aceinna_imu/examples/OpenRTK330LI/RTK_INS. However I had to add several lines to the platformio.ini file:

-I .pio/libdeps/OpenRTK/openRTK330-lib/Platform/Board/include
-I .pio/libdeps/OpenRTK/openRTK330-lib/Platform/Driver/include
-I .pio/libdeps/OpenRTK/openRTK330-lib/Platform/cJSON/inc
-I .pio/libdeps/OpenRTK/openRTK330-lib/Platform/CAN/include
-I .pio/libdeps/OpenRTK/openRTK330-lib/Platform/common/include
-I .pio/libdeps/OpenRTK/openRTK330-lib/Platform/Filter/include

Any idea why I would need to add those lines?

Log in to reply