OpenIMU330BI SPI doesn't work

Hi again,

now I tried a lot to and it still doesn't work. I'm running the preinstalled OpenIMU "IMU" application (and also tried it with installing the online available bin).

I removed the Jumpers from P1 to enable SPI mode but the IMU simply doesn't answer.
Also I tried different registers (hw version, software version, etc.) and SPI frequencies (from 100kHz to 1MHz) but there's no reply anyway.

Example Transmission

When i fit the jumpers the online-webserver connection works fine.

Do you have any idea what could be wrong here?

Best Regards

if possible, could you share with me your SPI drive codes?
pls try the sequence in below when start SPI mode communication(confirm 1&2 pins in P1 area are not connected):

  • start the SPI read program in your Master MCU.
  • Power on 330BI

other actions:

  1. update FW to FW2.1 in
  2. try other register, such as:
    or try burst read 0x3E

Hi, i already updated to FW2.1, changed SPI communication to 16bit and powering on the IMU after the SPI readout, but i still get no response at all. (at P1 all jumpers are disconnected)


confirm your pin connection of MISO, whether some connection problems it is.
such as: disconnect, or short connect to GND or other pins.
could you show some pics of your HW connections?

Thanks for your input but hardware was fine.
I now could fix the problem by rewriting the SPI+DMA framework: There was some bug where the RX handler wouldn't get called correctly.

Log in to reply