openIMU330BI cannot connect to Aceinna Navigation Studio

I got an openIMU330BI sample from the distributor to evaluate the performance. And I followed the installation guide to try to connect the device to Aceinna Navigation Studio for capturing IMU datas. After I tried several times, the status was still disconnected. And I am sure the usb to uart port worked properly. Can you give me some suggestions to handle this issue? And can you upload one example project about openIMU330 to Aceinna Navigation Studio? thanks.

@yxwrobert thanks for testing our IMU330BI, and could share more information from your side: Part Number, FW version? Pls give us the pic of your connection? (maybe NAV-VIEW can support you check the IMU information)

If your FW version is "OpenIMU330BI IMU 1.1.1'" and you have the EVK as below pic,
Follow steps to make it can be detected by python-driver:

  • Install STM32 ST-LINK Utility

  • Connect the EVK cables, and open SW(STM32 ST-LINK Utility), operating as pic:

  • Power off the IMU and go to use python-driver.

How to use python driver pls refer to other topic before

Here is my openIMU330BI connection screenshot. Maybe the firmware version is 0.0.22. Is that a problem when connecting to aceinna navigation studio?


@yxwrobert yes, you have to update the FW version to OpenIMU330BI_1.1.1, and then you can follow my step above and connect to ANS.
update the new FW steps in pics: OpenIMU330BI_1.1.1 download link


Log in to reply