Cannot connect to OpenIMU330BI EVK


Hi cek,

Here's another screenshot of the HTerm data with the data type set to Hex and the data scrolled back to the beginning. The first few bytes do indeed read 55 55 7A 31 as you can see.


your version of FW is 1.1.1, but calibrated area is broken, may be from your first flasing 1.1.1 you mentioned.

@say pls download the whole EEPROM bin file which include bootloader, fw and calibrated data, prepared for you. 1927300441_330BI EVK_whole EEPROM.bin

then pls follow below topic_5 steps to upload the bin to your IMU330:

reset the power, you should connect the ANS web.


Hi cek,

I installed the EEPROM bin file which you sent to me exactly according to the instructions under section 5 of the link above, starting at location 0x08000000, with a size of 0x30000. I set the 6 Option Bytes afterward and restarted the IMU board. I could not get the IMU to connect. I repeated the procedure again. I still cannot connect to the IMU with the OpenIMU Monitor. What should I do?

  1. check the serial data, what is sending from IMU now? your pic

I cannot get any data from the IMU over HTerm.

After establishing communication with the ST_LINK Utility, I tried to connect to each of the 5 COM ports using HTerm while the ST-LINK/V2 debugger LED is flashing alternately green and red. I could not get any data from the IMU over HTerm.

I also disconnected the IMU with the ST-LINK Utility and then again tried to connect to each of the 5 COM ports using HTerm while the ST-LINK/V2 debugger LED is constant red. I could not get any data from the IMU over HTerm.

  1. unlock the sectors
  2. upload bin file
  3. lock the sectors
  4. restart the IMU
    if right steps, it will working on well IMU HW.
    pls show pics of above steps, let's try again.


Hi cek,

I performed the steps above exactly as listed. Here is a screenshot of the ST-LINK Utility after successfully uploading the bin file, locking the sectors, and restarting the IMU:

I immediately saw good data over HTerm on COM14:

However, I still cannot connect to the OpenIMU Monitor at

What next steps should I take?

@say Hi Say,Now you have flashed the right image, the unit output the z1 package via uart interface. please use chrome browser, download the "IMU Server Ready-to-Use (Windows)" and try again. 2019-11-22_16h55_31.jpg 2019-11-22_16h53_10.jpg


Hi Li-YiFan,

I downloaded the IMU Server Ready-To-Use (Windows) using the Chrome browser and installed it as shown above. I still cannot connect to the IMU using ANS. After opening ANS, when I run Server_win32_1.1.1, a DOS console window opens briefly as shown here:


It gives the message as shown: "Cannot configure port, something went wrong. Original message: .."

How should I correct this problem?

First, pls save(backup) whole EEPROM bin file, and send to us. we need to check deeply.
follow the steps in topic_5, address 0x08000000, size 0x30000.

Second, pls use the testing server.exe try again, if still not, pls send to us the Server_log file which in same file with server.exe
thanks a lot.

@say Hi say, if the IMU Server Ready-To-Use (Windows) could connected with the OpenIMU330BI successfully, there will be the log 2019-11-23_09h29_02.jpg . The log picture you upload is Blurred, please send us a new one. BTW, could you send us a photo how you connected OpenIMU330BI with your computer. And if you could change a PC or USB port and test again?


Hello cek,

I downloaded the EEPROM bin file and ran the server file you sent me with the log. I cannot attach them here. How do I send these files to you?


Hi Li-YiFan,

Here is a screenshot of the Visual Studio Code terminal window after running It has the same output as Server_win32_1.1.1. The DOS command window disappears very quickly after running Server_win32_1.1.1, so the picture is blurry.



Here is a screenshot of the server log file:


send to us your saved EEPROM bin file and Server_log, by email to me
upload under the forum topic in below steps:

How about changing a computer and test?

I create one testing program for you, and we will fix the bug in next official release.


openIMU330BI not sending anything on UART at putty terminal, what problem may be there?

@jitendra ,sorry for reply you late.You mean you can't connect to navView?pls give us more information:
Do you have our EVK?
If you don't have EVK but you have your own communication circuit.Please provide your hardware and software information for our analysis.

Log in to reply