VG AHRS 1.0.1 for OpenIMU300RI doen't work!


I followed your instructions, but the problem still remains.

How I updated firmware

  • I downloaded your firmware(5020-....._plan.bin) and rename it as new.bin
  • I updated it by python-openimu driver.
~/hoge » openimu
This is openimu main routine.
Find device 0 times
system ports detected ['/dev/ttyS0', '/dev/ttyUSB0']
Autoconnected by last saved port
Connected(port:/dev/ttyUSB0 baudrate:57600) ....OpenIMU300ZA 5020-3309-01 1.1.0 SN:0
help : CLI help menu
exit : exit CLI
run : Operations defined by users
save : Save the configuration into EEPROM
connect : Find OpenIMU device
upgrade : Upgrade firmware
record : Record output data of OpenIMU on local machine
stop : stop recording outputs on local machine
server_start : start server thread and must use exit command to quit
get : Read the current configuration and output data
set : Write parameters to OpenIMU
>>upgrade new.bin
upgrade fw: new.bin
Restarting app ...
Find device 0 times
system ports detected ['/dev/ttyS0', '/dev/ttyUSB0']
Autoconnected by last saved port
Connected(port:/dev/ttyUSB0 baudrate:57600) ....OpenIMU300ZA 5020-3309-01 1.1.0 SN:0

How it looks now

  • I executed server_start
  • I opened web interface
  • I changed packet rate via SETTING -> Unit Configuration

Configuration looks good because openimu-driver says as follows.

>>Successfully Updated

But no data are shown.
I also tried baudrate 57600 but nothing changed.


I'm waiting for your advice!

P.S. As I mentioned, I pushed "Software Reset" button in NAV-VIEW when I was trying to figure out why I couldn't get any data.

"Before installing it, the IMU doesn't output any data such as acceleration, gyro."
when got it from plant, it should be working well. but your unit configuration not right, so after you received before installing IMU, what actions did you do?

Another colleague who bought this IMU says that he saw some numeric data on NAV-VIEW,
but at the moment I received it, it didn't output any data.
I'm not sure what the missing link is.

Is there any way to completely refresh it to plant shipping state?

May be already damaged by misoperation, we are trying to find solution for you, pls wait.

Sure. I wait for your solution.
Thank you for your job.

Thank you for your efforts.
Can I ask when you could give me what to do?

still find solution, still need more time, I can't reproduce your phenomenon now.

Thank you for quick reply. I understand.

@rintaro you need to do:

  • send commands to 300RI to lock one sector of the Unit, by UART.

  • power off and on, running with python diver and connected by ANS web page. maybe you need to change the packet rate, and click play button. check whether some data output.

  • after connected by ANS web, pls upgrade to below app, then power off an on, check how the status is in your side.

Thanks for the instruction.

I'm not sure that "55 55 4C 45..." worked or not (is there any way to confirm the command was accepted?)
But anyway I can see all-zero-data on web interface now.
Is this your expectation?

Screenshot from 2020-02-27 18-39-38.png

What do you think will happen if I push "Algorithm Reset" button on NAV-VIEW? Is that a bad idea?
(I've never pushed it)

@rintaro if it worked and will give feedback, if not you need change the baud rate and try again:

SW/Algorithm Reset generally no problem, cannot lead output data 0.

I still want to know what other actions you had done? e.g. send some commands to IMU.
for the CAL/CONF area may be already broken, but generally you cannot break it only by boot loader(boot loaderworking fine now) except some special commands received. or it can be recover well.
so i need time to find solution to recover your CAL/CONF area, working on it.
if you have other more information, pls let me know.

Log in to reply