OpenIMU300ZI: Can not be detected after upgrading GPS/INS app


I upgrade openIM300ZI EVK from IMU app to GPS/INS app by using the precompiled bin file. Everything is ok after upgrading it and It is ok for me to use GPS/INS it right after upgrading it. However, after I powered it off and reconnected it to PC, it cannot be detected anymore (No external GPS has been connected to openIMU300ZI yet). Could you please let me know what I should do?

Should I follow the same procedure described in the following?

Your help would be greatly appreciated.



based on your description, below actions are recommend to recover and supply more info to Aceinna:

  • backup whole EEPROM of your OpenIMU300ZI/ZA with ST-LINK, and send out BIN file by email or upload to Aceinna in forum, pls follow topic_4
  • pls download the FW precompiled bin file in ANS and upload to unit from start address 0x08010000, topic_8
  • power off unit, then restart Webserver_Win32_2.2.3.exe and your browser(Chrome), refresh browser page and try again.
  • at last, pls follow the procedure in your attached link if still invalid in all above actions

@cek Thanks very much for your prompt response. I did backup EEPROM of my OPENIMU300ZI . Unfortunately, I may pick up the wrong size number when backing up it . When I try it now, it is unsuccessful anymore. So I have to follow the procedure described in my attached link.

After connecting imu with my PC, I check the device manager, it shows:

I think IMU is connected through 4 virtual ports: COM9, 10, 11, and 12.

My steps are shown as below:

I am not sure which port index should be selected. Actually, I have tried with 1, 2, 4, and 5. No matter which port index I selected, It always shows "COM1: 230400 open failed".

Could you please provide me further instruction?



what is the SN number of your 300ZI? it is in side surface of module, include 10 figures, such as: 1808400528 in my side.
did you download the FW precompiled bin file in ANS and try to burn by ST-Link again?

@cek P/N number : 8550-3885-02, is this my SN number? Since I can not backup the whole EEPROM, I have not tried to burn it by using ST-link. but I did it before submitting my question.

it should be 10 figures, such as: 1808400528, no dash inside it.

@cek Only two number in my openimu300ZI:

or this number 1947100037

it is on the surface of 300zi module, pls check again.
backup current whole EEPROM of your OpenIMU300ZI/ZA with ST-LINK, and send out BIN file by email or upload to Aceinna in forum, pls follow topic_4

@cek SN number is 1908400135. I have tried to burn by ST-link again, it was unsuccessful. By the way, I donot know how to upload the BIN file to Aceinna forum. Could you please let me know which email address I should send out my BIN file to?

my email address:
I will prepare whole bin for you, and get back to you later, pls send your backup bin to me, thanks a lot for your info.

With the whole bin, it is working now.

@cek Thanks very much for your great support. All of the problems have been solved.

For the benefit of the forum, I would like to share my experience as follows:

  • After upgrading to INS, there may be some problems for the WIN webserver to identify the COM port . It may take more than 3~5 minutes to identify it or the COM port can not be identified. So it would be better to use it in Linux such as Ubuntu. It is very fast and stable. As long as following the instruction, it is not so difficult.

  • If you plan to apply the UBLOX-m9 (GPS - ZED F9P), use Ucenter to configure your ZED F9P as shown below: GPS_2_OpenIMU300ZI.jpg )GPS_ZED_F9P_2.png

Please note the baudrate should be changed from 9600 to 115200!!!!

Great works, thank a lot for your feedback info. best wishes for you.

Log in to reply