Can program unit, but then it won't communicate

Sorry to nag, but I'm evaluating this for a project which is on a relatively short timeframe.

Could you please let us know how long it is likely to take to respond to this issue and send through a replacement binary?

  1. Which INS app you are using? Is it from our official release?
  2. If the INS app is developed by you, could share it to public in app center?

If the INS app is developed by you ,is there any data output when you use a serial port debugging assistant tool?
You could also try to send command 'pG' in a serial port debugging tool to confirm if the device could response its device info.
The hex command is 0x55 0x55 0x70 0x47 0x00 0x5D 0x5F

If there is no response, you should check the source code.

hi, Luck, pls upload the prepared BIN for you. which is already upgrade to INS app.
pls refer steps to unlock you 0&2 sectors, recover the BIN, then lock the sectors again, steps of 4. How to backup and upload.
1908400050_OpenIMU300ZI EVK_Flash_latesFW4.1.2_3.1.8_0X100000_INS_230400_100hz.bin
wait your feedback.

Using ST-Link, the new bin you sent through will not connect to the webserver process.

Note that if I flash the bin which I backed up after receiving the unit, it does connect to the webserver, however when I then flash the (aceinna developed / official) INS (or other) application through the web interface, after which it becomes unresponsive until I flash the backup firmware again.

I am only trying to use official release binaries at this stage.

The INS app may take more time than other apps while connecting, and to make the connecting more fast, it is better to assign startup parameters when you use webserver.

The command looks like as below,
.\Webserver_Win32_2.3.2.exe -b {baudrate} -c {com port}

Please also try to send pG command with a serial port debug tool to make sure the device can response its device info.

I have tried all the public/official apps, and after flashing via the web interface the unit is no longer responsive.

I tried hard coding baudrate and UART device, but it makes no difference.

After flasing, sending 0x55 0x55 0x70 0x47 0x00 0x5D 0x5F has no response

Here is screenshot with the new bin.

I purchased a new unit, and tried swapping the green circuit board over to the old one. It made no difference, so the issue is in the IMU unit itself.

Please advise how I should go about returning the faulty one for replacement.


Please advise how I should go about returning the faulty one for replacement

Log in to reply