PC cannot detect RS232

I powered up the IMU just fine (12V 0.025A).
I made sure that the pin 4 - RS232-RX is connected to pin 2 of the DB9 connector, and pin 5 - RS232-TX is connected to pin 3 of the DB9 connector. Pin 5 DB9 connector to ground.
I have the RS232-USB connector with the driver installed to my PC.
I've installed NAV-View and make sure the COM ports are the same as the connector.
I've set up the automatic matching baud rate. However, the NAV-View says that I am not connected to the IMU. I've also tried all the manual baud rate options but still not connected.
Anything I can do to detect this signal?
In the manual, it says that there is a CD to install 8e974de7-27ab-4983-9551-84803d3a0d1c-image.png
How important is it to install .Net 2.0 framework and how can I obtain it? (cannot find it anywhere)
Thank you very much.

I found "Microsoft .NET Framework 2.0 Service Pack 2" can be downloaded from the link below.


The latest version of Nav-View can be downloaded from https://navview.blob.core.windows.net/web-resources/NAVVIEWV356.zip.
MS .NET Framework 4.0 is also included in the .zip file.

For RS232 connection, one possibility may be:

  1. The USB-RS232 connector has a male DB9;
  2. The MTLT unit RS232 port is connected to a cable, and the cable has a female DB9;
  3. The cable is connected to the USB-RS232 connector.
    Then, you need connect RX of MTLT to RX, and TX to TX of the cable.

If this is not the case, please provide more details about your connection. A picture will help.

@Dong-xiaoguang Hello Xiaoguang,
Thank you very much for your reply. I have tried your suggestions. I have installed the latest Nav-View and the .NET framework. I also made sure the connections are consistent with the RX and TX. I have also checked if the connections are okay using a multimeter. I still cannot see anything from NAV-View. Also, I tried detecting the CAN messages and it worked just fine. The problem is only about detecting rs232. Is there anything I miss?


  1. according to the mtlt datasheet, mtlt pin4 (blue wire) is rx and pin5 (white wire) is tx;
  2. Is the following connector a female one? If yes, mtlt pin4 (blue wire) rx should be connected with pin3 (rx) of the female db9, and mtlt pin5 (white wire) tx should be connected with pin2 (tx) of the female db9. For the female db9 and the male db9 of the rs232-usb connector, it is rx to tx and tx to rx.
  3. The RS232 communication is silent by default. After connection established, there may still be no data. But the red in the following fig will turn green. And then you can use nav-view-->configuration to set an ODR to the output data.

If this still cannot solve your problem, please make sure the rs232-usb works. And I can get an application engineer to help you.

@Dong-xiaoguang Thank you very much. I appreciate your help. I swapped the blue and white wires on the db9 connector. Now it works. Before, I followed the user manual documentation, but it seems that the manual is wrong then. It works now with blue wire to pin 3 of db9, and white wire to pin 2 of db9.

yes, thx for reminder. not so exactly description here in our manual.
Later we will update to confirm that keep sensor RX connect to TX pin of the wire harness connector.

The exactly clear description in below pic:


I have exactly the same problem.

  • I have bought two of those sensors a few month ago, NAV-VIEW had no problems with communication or changing settings.
  • I have bought another two, a few days ago. Can not communicate with any one of them through RS232. NAV-VIEW just can not see them. There is no activity on sensor's transmit line at all.

I would appreciate help from ACEINNA. You have great sensors, once the users can make them work...

P/N 8360-3305--054, serial numbers - 2103000888 , 210300874. Is the firmware in them "updated"?

I think your unit is MTLT305D, do you mean that not working with NAV-VIEW after you just received it?
you can select the right port(COM xxx found in device manager of Operating System-OS) in your PC, by setup menu of NAV-VIEW.
get version on bottom of NAV-VIEW, after connected well

CAN J1939:
How about CAN? can you receive some data in CAN, meanwhile you can send some data with ID(29bits) to wake up it.
Get FW version, (id-0x18EAFF00, data-00 FE DA)

if CAN is working with some data received, it means working well, the root cause may be connection or configuration in OS.
after working well in CAN or in RS232, then we can get FW version of the unit, then we can check whether FW upgradation is needed or not.

Log in to reply