OPENIMU300RI / Mtlt305D are always used in vehicles such as cars and tractors via CAN interface, so the RS-232 messages are QUIET by default.

Nav-view software can help you configure unit to send messages via RS-232 interface:

  1. Connec unit and PC with a RS-232 to USB cable.
  2. Open Nav-view, it can scan all available COM ports and try some usual baudrate, then connect unit automatically. If the bottom of GUI become green, it means Nav-view has connected with unit successfully, rather, if it is red as below picture, it means hasn't connected. You can try to replug usb port or re-open Nav-view.
  3. After the unit connect with Nav-view successfully, you can configure the output rate in configuration sheet.

If the unit can't connect with Nav-view:

  1. Could you please tell me which sample code or application bin you downloaded to unit, it is better to provide a screenshot.
  2. Could you please try to receive messages via CAN? Unit outputs messages all the time. So we can make sure the unit is still alive after you upload bin/firmware last time.



Thanks for the quick response. Unfortunately I have tried to connect using NAV_VIEW in automatic mode and in manual mode. No response at all.

I have to units, an EVK and a standard 300RI (without the evaluation Kit). Today I have tried to connect the standard 300RI unit with the same results. No connection.

I think my problem is more related with software? But i have tried in two different computers and in both cases the pyton executable (pyton server.exe) was not able to connect to any of the two units. In WIN7 64-bit I receive a message from the app but in W10 the app says that is trying to connect to the specific port but never connects. No error messages.

Maybe there is a problem with the wire provided ? The 6 pin one that connects to the RS-232/CAN. As i have been able to connect via JT2 and upload software to the unit successfully. Seems that the problem could be between the unit and the computer.

Are there any tests that I can do using a Digital Multimeter to ensure that the 6pin connector/RS-232 is working properly?



pls show your HW connection pic and SW status pic what you do

@david i think it is still connection problems, pls check 2 points again:

  1. line:
  2. system device management found it yet:

how about your status now?

Thanks for the response. I am busy with other tasks and haven´t time to continue with the IMU unit.
I will check if there the wire connections are correct, by checking with a digital multimeter the RS-232 pins and the 6-pin connector. I will check for electrical continuity.

When I connect the device to my computer, in the devide management I always see that something is connected. Furthermore when I connect the IMU, the pyton.exe looks properly in the COM ports where the IMU is connected.

Thanks. I´ll let you know.


This is being a nightmare, I have checked for continuity between 6pin conector and DB9 pins and was OK.

Please see the next picture: I have build and then upload a project (imported example). Its OK. isnt it?

IMG_20190720_220934 (1).jpg

After that I disconnect all wires (except external DC) and connect the 6 pin -rs232 to my rs232 to usb cable. I connect, the device is properly recognized (the computer beeps). And again the same problem. Neither NAV-VIEW nor pyton detects the IMU sensor.

I am getting crazy with this sensor.



  1. your device is OpenIMU300RI, if flashed the FW or App for 300ZA, or it will be not working.
    so you need flash back to 300RI firm ware by ST-LINK under below steps:
    bin file: 5020-3309-01_OpenIMU300RI_1.0.24.bin
  2. currently only NAV-VIEW support RI now, so pls try to connect it by below steps:
    3, 300RI send out the CAN message, it will send the messages: acceleration and gyro and slop angle information(pitch, roll), related format can refer to user manual of MTLT305D

Found the problem. The RS-232 to USB conversor wire was broken or did not work properly.
I have used a computer with a standard RS-232 port and the software works properly.

Thanks to all for your support.

We have tested our MTLT305D directly connected to a PC and was working. We have a data logger CANedge2 and tested both channels are working since we managed to power it up and a USB connected to the CH2 was powered by it. Now my query is how to configure the MTLT305D to connect to this data logger? Can anybody help me on this please.


@JimmyEG you mentioned "We have a data logger CANedge2 and tested both channels are working ", already connected, right? so not understand your request.
pls complement:

  1. which protocol data logger supported?
  2. how to connected on HW in your side? it is better to show your connection style by pic
  3. CAN protocol you used, right? not RS232 connection.
  4. after connection well, use NAV-VIEW to configure MTLT: DOWNLOAD
  5. refer to MTLT user manual: link
Log in to reply