How to reset OpenIMU300ZA EVK

Yes please. Send a testing EEPROM image.

Thanks @cek . Have received the mail, but is blocked due to organisation policy. Can you please forward to my personal id?

hi @cek . am able to upload the firmware to IMU using visual studio . but , when i start server am getting :
scanning ports
testing port com9
testing port com10
testing port com11
testing port com12
'utf-8' codec cant decode byte 0xbb in position 2: invalid start byte

@sharat You can flash Framework or IMU example into IMU and performance should be the same. If calibration damaged (data is all 0 or does not make sense) you ask our support team to create image for you with required calibration data if you provide IMU serial number. After you receive this image - you will need to flash it by ST-Link from address 0x08000000 and you will need to write protect sectors 0 and 2.
Actually, try to check if these sectors write protected first and protect if not before requesting image. Also you can capture image of you unit from address 0x08000000 with length 0x80000 , save it to file and send to support team for checking.

Thanks @Andrey-Bondarev . Have write protected the sectors 0 and 2. now when I run the server, i am getting below error
scanning ports
Testing port /dev/ttyS4
Testing port /dev/ttyS0
Testing port /dev/ttyUSB3
Testing port /dev/ttyUSB2
Testing port /dev/ttyUSB1
Testing port /dev/ttyUSB0
'utf8' codec can't decode byte 0xbb in position 2: invalid start byte

Will be sending mail to support team to create an image attaching the current image file.

The image sent by @cek is working now. I am able to get the output in the ANS. But when I try to run in the terminal, I am getting some junk data or the data in non-readable format as below,
<˜­.¼.¿¤~Æ>›Œœ<™&Z¾Ž..?eå>YˆF¾. ñAÙjUUs14†q!.....€.¡@.§ƒ<H..¼Ñµ¿Óò«>®Ÿe½K£Œ¾¥..?Ò7>«TF¾. ñA£áUUs14êq!.3333³.¡@ÄM“<hu.¼-ˁ¿±óÊ>Ž%‰=j䐾.>.?.r>ljF¾. ñAï8UUs14Nr!.gfffæ.¡@Ðì„<¨ž&¼ï„¿É@Ï>.K,¼—.|¾º..?4.>5ûE¾. ñA¨‰UUs14²r!.š™™™. ¡@È.<Àd.¼.¿©žÛ>!‹q½.d¾ã..?q«>ƒjF¾. ñA©'UUs14.s!.ÍÌÌÌL ¡@àæ€<(¬.¼.ρ¿!ö½>..­<äKy¾‹..?.‚.>c4F¾. ñAëÊUUs14zs!.....€ ¡@$å†<àà.¼s±¿ºªÕ>ܵà<,.Ÿ¾¡Ã.?¿Û.>ÑzF¾. ñA6¬UUs14Þs!.3333³ ¡@ì{‡<ˆø¼Mn¿0.´>eêÙ¼|¬‹¾bå.?¾î>. F¾. ñAXßUUs14Bt!.gfffæ ¡@.›Ž<ðÞ1¼.¡¿QÏÃ>aW(¼h呾×Ï.?...>ÏFF¾. ñAïUUs14¦t!.š™™™.!¡@”€<ˆ].¼H¯¿ÝÎ>Œ.¶¼_]‡¾ïô.?z?>ÔF¾. ñAÊ¥UUs14u!.ÍÌÌÌL!¡@ ><@ä ¼”¿žXå>œ.l¼AM€¾¸î.?&.>nbF¾. ñAÕYUUs14nu!.....€!¡@.$Œ<àæ.¼ö˜¿¥Zè>…±.½ðü[¾“í.?.á>rXF¾. ñA®~

So do i need to do any changes or configurations in order to get the data in terminal in the readable format?

refer to our ANS page and go through link:
if still not working, pls show some clear pic of your HW and SW, it will be better for understanding your status.

Its working fine in ANS. But we want to get the output in the terminal same as what it is getting saved in .csv file. Is there any way to do that?

you mean changed the saving format in csv file? when we save data to file

Yes. Is it possible?

Log in to reply